欢迎光临
专注android技术,聚焦行业精粹,我们一直在努力

Hacker入门-Deepin Linux下的Metasploit安装及优化

作为一个重要的安全检测工具,Metasploit位置举足轻重,里边有数百个windows的安全漏洞攻击工具,让世界上的电脑处于不被保护状态,瞬息之间成为被攻击和操纵的对象。下面就是来进行在Deepin15.5操作系统平台上,集成Metasploit的方法。
内容分4步:1 配置Kali Linux源 2安装metasploit 3 解决数据库连接问题 4 建立数据库的本地索引

1 配置Kali Linux源
由于官方源在国外,而且被墙,所以转成国内企业源,下面几家支持对Kali源,把地址加入Deepin的软件源当中。

2安装metasploit
#安装全部Kaili武器,不过有和系统的库有冲突,相当部分武器不能完全兼容Deepin库

#这里只安装metasploit

3 解决数据库连接问题
metasploit里边有数千windows的漏洞记录,由此使用postgresql数据库进行维护,当启动metasploit的时候,要连接数据库,才能查询对应的windows漏洞。在此为metasploit在metasploit中建立数据库。
如下步骤:1)修改postgresql的权限,2)切换到root用户,3)然后再切换到postgresql,然后创建用户,和数据库
1)修改postgresql的权限

保存后执行下面的命令重新加载配置文件:

2)切换到root用户设置账户

在metasploit的安装目录 /usr/share/metasploit-framework/下新建database.yml文件,内容如下

4 建立数据库的本地索引
默认msf里边是没有开启缓存索引的,所以找起windows的漏洞记录会很慢,所以我们要建立索引。
//下面是管理员权限进入

重建缓存 ,这个是后台运行的,要等个10分钟才有效果

为下次启动方便,可以写一个脚本,这样,每次启动metasploit,就可以顺便启动sql,postgresql默认是不开机启动的。

使用方法例子:


—-启动metasploit


—-使用windows08_067号漏洞攻击

Enjoy~

赞(0) 打赏
未经允许不得转载:花花鞋 » Hacker入门-Deepin Linux下的Metasploit安装及优化
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

国内精品Android技术社区

联系我们

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏